Office 365 - issue provisioning new Exchange Online mailboxes
Incident Report for RM Unify & Apps
Resolved
The issue has been confirmed as resolved and service has returned to normal.
Posted Jun 10, 2020 - 14:06 BST
Monitoring
We are aware of an issue with Exchange Online that may affect the ability to onboard new users to the Exchange Online service. For O365 tenancies federated to RM Unify, the impact is that new user accounts should be created in Office 365, but there may be a delay in the users' mailboxes being created.

For further updates to the issue, your Office 365 administrator should refer to advisory EX208974 in the Microsoft 365 Admin Center.
Posted Apr 09, 2020 - 12:12 BST
This incident affected: 3rd Party Apps.