RM Easimaths Incident
Incident Report for RM Unify & Apps
Resolved
RM Easimaths is stable and we have seen improved performance over the last few days following changes we have made. We continue to monitor the site to optimise performance. If the site is running slow then please use it after 3pm when the site is quieter.
Posted Jun 11, 2020 - 10:53 BST
Update
RM Easimaths is stable and we have seen improved performance over the last few days following changes we have made. We continue to monitor the site to optimise performance. If the site is running slow then please use it after 3pm when the site is quieter.
Posted Apr 01, 2020 - 13:00 BST
Update
We have made some more changes to the servers this weekend, however we can see that some customer sessions are still slow. We are working to make further changes to improve performance. The issue is caused by the demand for the service during this unprecendented period. Thank you for you patience.
Posted Mar 30, 2020 - 11:42 BST
Monitoring
Following some changes yesterday and overnight we are seeing an improved performance from RM Easimaths today. We will continue to closely monitor the performance and make changes as needed. Thank you for bearing with us.
Posted Mar 26, 2020 - 10:43 GMT
Update
RM Easimaths is back up after some configuration option changes. Due to the volume of users we anticipate the system running slow at times. We are working on more changes to increase the capacity of the system. Please bear with us during this period.
Posted Mar 25, 2020 - 10:08 GMT
Update
We're sorry but due to unprecendented demand for RM Easimaths we need to increase our capacity and this will take a few hours. We are aiming to get you back up and running by tomorrow morning. Please bear with us. Thank you, the RM Easimaths team.
Posted Mar 24, 2020 - 15:42 GMT
Investigating
We are aware that users are experiencing intermittent issues logging in with RM EasiMaths. Our engineers are currently investigating this with high priority.
Posted Mar 24, 2020 - 12:37 GMT
This incident affected: RM Apps (RM Easimaths).