Glow - Exchange Online - Receiving and Forwarding External Email

Incident Report for RM Unify & Apps

Resolved

Incident start: 26/05/2021 01:06PM BST
Incident update: 26/05/2021 03:24PM BST
Elapsed time: about 2 hours

Microsoft have advised us that this issue is now resolved.
Posted May 26, 2021 - 15:53 BST

Identified

Incident start: 26/05/2021 01:06PM BST

Microsoft have raised incident EX258320 to advise of an issue that they are investigating where users may be unable to forward or receive external email. This is currently under investigation by Microsoft and further updates will follow.
Posted May 26, 2021 - 13:26 BST
This incident affected: 3rd Party Apps.