Issue with RM Easimaths
Incident Report for RM Unify & Apps
Resolved
There have been no further issues during our period of monitoring.
Posted May 19, 2023 - 11:31 BST
Monitoring
Issue has been resolved and Easimaths activities are working as expected. We are monitoring the service closely.
Posted May 18, 2023 - 14:59 BST
Investigating
We are aware of an issue where users are unable to play activities in RM Easimaths. Our engineers are investigating this issue as a high priority.
Posted May 18, 2023 - 10:35 BST
This incident affected: RM Apps (RM Easimaths).