Exchange Online service alert
Incident Report for RM Unify & Apps
Resolved
Microsoft Incident ID: EX255429

Status: Service Restored

Title: Some users may have been unable to send and receive external email messages within the Exchange Online service

User Impact: Users may have been unable to send and receive external email messages within the Exchange Online service.

Final status: We've confirmed that cache has finished updating and the affected infrastructure has returned to service. After further monitoring, we've confirmed that this has resolved the issue.

Scope of impact: Impact was specific to users who were served through the affected infrastructure located in Europe.
Posted May 10, 2021 - 13:21 BST
Investigating
Title: Some users may be unable to send and receive external email messages within the Exchange Online service

User Impact: Users may be unable to send and receive external email messages within the Exchange Online service.

Current status: Microsoft are reviewing and analysing transport logs to identify the root cause of impact and determine their next troubleshooting steps.

Scope of impact: Impact is specific to users who are served through the affected infrastructure located in Europe.
Posted May 10, 2021 - 11:25 BST
This incident affected: 3rd Party Apps.