Customers are unable to access RM Easimaths

Incident Report for RM Unify & Apps

Resolved

This issue is resolved now
Posted Feb 04, 2025 - 10:43 GMT

Investigating

An error message is displayed after logging on to RM Easimaths
Posted Feb 03, 2025 - 10:57 GMT
This incident affected: RM Apps (RM Easimaths).