Glow - Microsoft Teams - unable to launch the Teams application on the Chrome browser

Incident Report for RM Unify & Apps

Resolved

This issue has been resolved by Microsoft.
Posted Jun 21, 2021 - 09:49 BST

Identified

Please note that some users may be unable to launch the Teams application on the Chrome browser
This is currently under investigation by Microsoft and further updates will follow
As an alternative way to access Teams, Microsoft recommend users to use Microsoft Edge, or the Teams desktop app
Posted Jun 04, 2021 - 10:42 BST
This incident affected: 3rd Party Apps.